Holddown is a loop-prevention mechanism employed by distance vector routing protocol. This feature prevents a router from learning new information about a failed route. When a router receives an information about an unreachable route, a holddown timer is started. The router ignores all routing updates for that route until the timer expires (by default, 180 seconds in RIP). Only updates allowed during that period are updates sent from the router that originally advertised the route. If that router advertise the update, the holddown timer is stopped and the routing information is processed.
Browse and Watch Networking Videos CCNA, Ethical Hacking, Windows hacking videos with captions in Hindi and other languages.
Friday, 28 March 2014
Rip loop prevention methods 4(Route poisoning)
Route
poisoning
Route
poisoning is another method for preventing routing loops employed by distance
vector routing protocols. When a router detects that one of its directly
connected routes has failed, it sends the advertisment for that route with an
infinite metric ("poisoning the route"). A router that receives the
update knows that the route has failed and doesn't use it anymore.Rip loop prevention methods 3(poison reverse)
Poison Reverse
When a router receives a route poisoning, it sends an update back to the
router from which it received the route poisoning,
When a router receives a route poisoning, it sends an update back to the
router from which it received the route poisoning,
Rip loop prevention methods 2(Triggered updates)
Triggered updates
Well since we are discussing distance vector routing protocols, all routers will eventually converge, but updates are sent out every 30 seconds with a full routing table when things are operating normally. In the case of a failed interface the neighboring router would immediately send out and update, but it would only send out a poison route with a metric of 16. The router would also temporarily suspend split horizon and send out this poisoned route back in the direction it received an update. this would be called split horizon with poison reverse. As soon as the route is considered dead, the hold down timer starts and the routers will not believe any more information about the poisoned route until the hold expires.
Well since we are discussing distance vector routing protocols, all routers will eventually converge, but updates are sent out every 30 seconds with a full routing table when things are operating normally. In the case of a failed interface the neighboring router would immediately send out and update, but it would only send out a poison route with a metric of 16. The router would also temporarily suspend split horizon and send out this poisoned route back in the direction it received an update. this would be called split horizon with poison reverse. As soon as the route is considered dead, the hold down timer starts and the routers will not believe any more information about the poisoned route until the hold expires.
Rip loop prevention methods 1(split horizon)
Split Horizon
Distance vector protocols are susceptible to routing loops. Split horizon is one of the features of distance vector routing protocols that prevents them. This feature prevents a router from advertising a route back onto the interface from which it was learned.
Distance vector protocols are susceptible to routing loops. Split horizon is one of the features of distance vector routing protocols that prevents them. This feature prevents a router from advertising a route back onto the interface from which it was learned.
Thursday, 27 March 2014
Tuesday, 25 March 2014
Standard ACL(host Blocking)
In this example i m trying to block 30.0.0.1 host from my network which is HCL(10.0.0.0)
HCL(config)#ip access-list standard hcl
HCL(config-std-nacl)#deny host 30.0.0.1
HCL(config-std-nacl)#permit any
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group hcl out
........................OR................................
HCL(config)#ip access-list standard 10
HCL(config-std-nacl)#deny host 30.0.0.1
HCL(config-std-nacl)#permit any
HCL(config-std-nacl)#exit
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
........................OR................................
HCL(config)#access-list 10 deny host 30.0.0.1
HCL(config)#access-list 10 permit any
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
HCL(config)#ip access-list standard hcl
HCL(config-std-nacl)#deny host 30.0.0.1
HCL(config-std-nacl)#permit any
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group hcl out
........................OR................................
HCL(config)#ip access-list standard 10
HCL(config-std-nacl)#deny host 30.0.0.1
HCL(config-std-nacl)#permit any
HCL(config-std-nacl)#exit
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
........................OR................................
HCL(config)#access-list 10 deny host 30.0.0.1
HCL(config)#access-list 10 permit any
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
Standard ACL
In this example i m trying to block 30.0.0.0 network for my network which is HCL(10.0.0.0)
HCL(config)#ip access-list standard HCL
HCL(config-std-nacl)#deny 30.0.0.0 0.255.255.255
HCL(config-std-nacl)#permit any
HCL(config-std-nacl)#exit
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group HCL out
........................OR................................
HCL(config)#ip access-list standard 10
HCL(config-std-nacl)#deny 30.0.0.0 0.255.255.255
HCL(config-std-nacl)#permit any
HCL(config-std-nacl)#exit
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
........................OR................................
HCL(config)#access-list 10 deny 30.0.0.0 0.255.255.255
HCL(config)#access-list 10 permit any
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
HCL(config)#ip access-list standard HCL
HCL(config-std-nacl)#deny 30.0.0.0 0.255.255.255
HCL(config-std-nacl)#permit any
HCL(config-std-nacl)#exit
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group HCL out
........................OR................................
HCL(config)#ip access-list standard 10
HCL(config-std-nacl)#deny 30.0.0.0 0.255.255.255
HCL(config-std-nacl)#permit any
HCL(config-std-nacl)#exit
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
........................OR................................
HCL(config)#access-list 10 deny 30.0.0.0 0.255.255.255
HCL(config)#access-list 10 permit any
HCL(config)#interface fastEthernet 0/0
HCL(config-if)#ip access-group 10 out
Sunday, 23 March 2014
Extended ACL (network to Host blocking)
Extended ACL for network to Host blocking
HCL(config)#ip access-list extended hcl
HCL(config-ext-nacl)#deny icmp 30.0.0.0 0.255.255.255 host 10.0.0.1
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group hcl out
........................................OR.................................................
HCL(config)#ip access-list extended 110
HCL(config-ext-nacl)#deny icmp 30.0.0.0 0.255.255.255 host 10.0.0.1
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
........................................OR.................................................
HCL(config)#access-list 110 deny icmp 30.0.0.0 0.255.255.255 host 10.0.0.1
HCL(config)#access-list 110 permit ip any any
HCL(config)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
Extended ACL (Host to Host blocking)
Extended ACL for Host to Host blocking
HCL(config)#ip access-list extended hcl
HCL(config-ext-nacl)#deny icmp host 30.0.0.1 host 10.0.0.1
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group hcl out
........................................OR.................................................
HCL(config)#ip access-list extended 110
HCL(config-ext-nacl)#deny icmp host 30.0.0.1 host 10.0.0.1
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
........................................OR.................................................
HCL(config)#access-list 110 deny icmp host 30.0.0.1 host 10.0.0.1
HCL(config)#access-list 110 permit ip any any
HCL(config)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
Extended ACL (Host to Network blocking)
Extended ACL for Host to Network blocking
HCL(config)#ip access-list extended hcl
HCL(config-ext-nacl)#deny icmp host 30.0.0.1 10.0.0.0 0.255.255.255
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group hcl out
.......................................OR...........................................
HCL(config)#ip access-list extended 110
HCL(config-ext-nacl)#deny icmp host 30.0.0.1 10.0.0.0 0.255.255.255
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
.......................................OR...........................................
HCL(config)#access-list 110 deny icmp host 30.0.0.1 10.0.0.0 0.255.255.255
HCL(config)#access-list 110 permit ip any any
HCL(config)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
Extended Access list(network to network blocking)
Extended Access list(network to network blocking)
HCL(config)#ip access-list extended hcl
HCL(config-ext-nacl)#deny icmp 30.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group hcl out
..........................................OR............................................
HCL(config)#ip access-list extended 110
HCL(config-ext-nacl)#deny icmp 30.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
..........................................OR............................................
HCL(config)#access-list 110 deny icmp 30.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
HCL(config)#access-list 110 permit ip any any
HCL(config)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
HCL(config)#ip access-list extended hcl
HCL(config-ext-nacl)#deny icmp 30.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group hcl out
..........................................OR............................................
HCL(config)#ip access-list extended 110
HCL(config-ext-nacl)#deny icmp 30.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
HCL(config-ext-nacl)#permit ip any any
HCL(config-ext-nacl)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
..........................................OR............................................
HCL(config)#access-list 110 deny icmp 30.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
HCL(config)#access-list 110 permit ip any any
HCL(config)#inter fa 0/0
HCL(config-if)#ip access-group 110 out
Standard Access control list commands
Standard Access control list
IBM(config)#ip access-list standard hcl
IBM(config-std-nacl)#deny 30.0.0.0 0.255.255.255
IBM(config-std-nacl)#permit any
IBM(config)#inter fastEthernet 0/0
IBM(config-if)#ip access-group hcl out
.....................OR...........................
IBM(config)#ip access-list standard 10
IBM(config-std-nacl)#deny 30.0.0.0 0.255.255.255
IBM(config-std-nacl)#permit any
IBM(config)#inter fastEthernet 0/0
IBM(config-if)#ip access-group 10 out
.....................OR...........................
IBM(config)#access-list 10 deny 30.0.0.0 0.255.255.25
IBM(config)#access-list 10 permit any
IBM(config)#inter fastEthernet 0/0
IBM(config-if)#ip access-group 10 out
Block a host through standard ACL
hcl(config)#ip access-list standard hcl
hcl(config-std-nacl)#deny host 30.0.0.1
hcl(config-std-nacl)#permit any
hcl(config)#inter fastEthernet 0/0
hcl(config-if)#ip access-group hcl out
.....................OR...........................
hcl(config)#ip access-list standard 10
hcl(config-std-nacl)#deny host 30.0.0.1
hcl(config-std-nacl)#permit any
hcl(config)#inter fastEthernet 0/0
hcl(config-if)#ip access-group 10 out
.....................OR...........................
hcl(config)#ACcess-list 10 deny host 30.0.0.1
hcl(config)#access-list 10 permit any
hcl(config)#inter fastEthernet 0/0
hcl(config-if)#ip access-group 10 out
IBM(config)#ip access-list standard hcl
IBM(config-std-nacl)#deny 30.0.0.0 0.255.255.255
IBM(config-std-nacl)#permit any
IBM(config)#inter fastEthernet 0/0
IBM(config-if)#ip access-group hcl out
.....................OR...........................
IBM(config)#ip access-list standard 10
IBM(config-std-nacl)#deny 30.0.0.0 0.255.255.255
IBM(config-std-nacl)#permit any
IBM(config)#inter fastEthernet 0/0
IBM(config-if)#ip access-group 10 out
.....................OR...........................
IBM(config)#access-list 10 deny 30.0.0.0 0.255.255.25
IBM(config)#access-list 10 permit any
IBM(config)#inter fastEthernet 0/0
IBM(config-if)#ip access-group 10 out
Block a host through standard ACL
hcl(config)#ip access-list standard hcl
hcl(config-std-nacl)#deny host 30.0.0.1
hcl(config-std-nacl)#permit any
hcl(config)#inter fastEthernet 0/0
hcl(config-if)#ip access-group hcl out
.....................OR...........................
hcl(config)#ip access-list standard 10
hcl(config-std-nacl)#deny host 30.0.0.1
hcl(config-std-nacl)#permit any
hcl(config)#inter fastEthernet 0/0
hcl(config-if)#ip access-group 10 out
.....................OR...........................
hcl(config)#ACcess-list 10 deny host 30.0.0.1
hcl(config)#access-list 10 permit any
hcl(config)#inter fastEthernet 0/0
hcl(config-if)#ip access-group 10 out
Friday, 21 March 2014
Wednesday, 19 March 2014
Saturday, 15 March 2014
Friday, 14 March 2014
Link for job in Span infotech mohali jobs
Link for job in Span infotech mohali jobs
- Address: Industrial Area Mohali, Sector 75, Sahibzada Ajit Singh Nagar, Punjab 140308
Download link packet tracer 6.0
If you want to download the Cisco packet tracer than you can download from this link
Packet tarcer 6.0
Packet tarcer 6.0
Tuesday, 11 March 2014
Monday, 10 March 2014
Saturday, 8 March 2014
Friday, 7 March 2014
Thursday, 6 March 2014
Wednesday, 5 March 2014
Tuesday, 4 March 2014
Monday, 3 March 2014
Intervlan NAT ACL
Switch 1 config
Building configuration...
Current configuration : 1654 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
switchport access vlan 10
!
interface FastEthernet0/6
switchport access vlan 10
!
interface FastEthernet0/7
switchport access vlan 10
!
interface FastEthernet0/8
switchport access vlan 10
!
interface FastEthernet0/9
switchport access vlan 10
!
interface FastEthernet0/10
switchport access vlan 10
!
interface FastEthernet0/11
switchport access vlan 10
!
interface FastEthernet0/12
switchport access vlan 10
!
interface FastEthernet0/13
switchport access vlan 10
!
interface FastEthernet0/14
switchport access vlan 10
!
interface FastEthernet0/15
switchport access vlan 10
!
interface FastEthernet0/16
switchport access vlan 10
!
interface FastEthernet0/17
switchport access vlan 10
!
interface FastEthernet0/18
switchport access vlan 10
!
interface FastEthernet0/19
switchport access vlan 10
!
interface FastEthernet0/20
switchport access vlan 10
!
interface FastEthernet0/21
switchport access vlan 10
!
interface FastEthernet0/22
switchport access vlan 10
!
interface FastEthernet0/23
switchport access vlan 10
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
switch 2
Subscribe to:
Posts (Atom)